$re = '/^master|release|tag\/.*$/m';
$str = 'tag/1.2.1
master/
release
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);