package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^master|release|tag\/.*$`)
var str = `tag/1.2.1
master/
release
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}