re = /(?<slot>\d+)\/(?<daughter_slot>\d+)\/(?<port>\d+)/m
str = ' slot/daughter_slot/port
3/1/1 regexp for slot only?
3/1/10 regexp for daughter_slot only?
3/1/2 regexp for port only?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end