// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{1,3}([ ,]?\d{3})*([.]\d+)?$").unwrap();
let string = "For a positive payment amount (US, UK, CA)
Valid
1000
1,000
1,000.99
1000.00
1,000,000.12
Invalid
100000,99
1,0.00
1,000,00.00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}