$re = '/^\d{1,3}([ ,]?\d{3})*([.]\d+)?$/m';
$str = 'For a positive payment amount (US, UK, CA)
Valid
1000
1,000
1,000.99
1000.00
1,000,000.12
Invalid
100000,99
1,0.00
1,000,00.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);