package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,3}([ ,]?\d{3})*([.]\d+)?$`)
var str = `For a positive payment amount (US, UK, CA)
Valid
1000
1,000
1,000.99
1000.00
1,000,000.12
Invalid
100000,99
1,0.00
1,000,00.00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}