using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{1,3}([ ,]?\d{3})*([.]\d+)?$";
string input = @"For a positive payment amount (US, UK, CA)
Valid
1000
1,000
1,000.99
1000.00
1,000,000.12
Invalid
100000,99
1,0.00
1,000,00.00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}