#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,3}([ ,]?\d{3})*([.]\d+)?$"
Local $sString = "For a positive payment amount (US, UK, CA)" & @CRLF & _
"" & @CRLF & _
"Valid" & @CRLF & _
"1000" & @CRLF & _
"1,000" & @CRLF & _
"1,000.99" & @CRLF & _
"1000.00" & @CRLF & _
"1,000,000.12" & @CRLF & _
"" & @CRLF & _
"Invalid" & @CRLF & _
"100000,99" & @CRLF & _
"1,0.00" & @CRLF & _
"1,000,00.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")