$re = '/(?:\d+h)?(?:\d+m)?(?:\d+s)?/';
$str = '1h1m1s,1h1h1s,1s1m1h';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);