package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\d+h)?(?:\d+m)?(?:\d+s)?`)
var str = `1h1m1s,1h1h1s,1s1m1h`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}