package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^<TAG>]+[^<\TAG>]`)
var str = `<TAG>one<TAG>two</TAG>one</TAG>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}