import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i):/([^:]+)(?=/lib/neo4j-kernel-\\S+\\.jar)";
final String string = " java -cp /var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/concurrentlinkedhashmap-lru-1.4.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/lucene-core-3.6.2.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-backup-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-cluster-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-com-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-consistency-check-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-csv-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-cypher-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-cypher-compiler-1.9-2.0.4.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-cypher-compiler-2.0-2.0.4.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-cypher-compiler-2.1-2.1.8.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-cypher-compiler-2.2-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-graph-algo-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-graph-matching-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-ha-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-import-tool-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-io-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-jmx-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-kernel-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-lucene-index-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-management-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-primitive-collections-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-query-logging-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-shell-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-udc-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/neo4j-unsafe-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/netty-3.6.3.Final.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/opencsv-2.3.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/org.apache.servicemix.bundles.jline-0.9.94_1.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/parboiled-core-1.1.7.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/parboiled-scala_2.10-1.1.7.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/scala-library-2.10.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/server-api-2.2.5.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/lib/slf4j-api-1.7.7.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/system/lib/bcprov-jdk16-140.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/system/lib/commons-beanutils-1.8.3.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/system/lib/commons-compiler-2.6.1.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/system/lib/commons-configuration-1.10.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/system/lib/commons-digester-2.1.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/system/lib/commons-io-2.4.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/system/lib/commons-lang-2.6.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/system/lib/commons-logging-1.1.1.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/system/lib/jackson-core-asl-1.9.13.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/system/lib/jackson-jaxrs-1.9.13.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/system/lib/jackson-mapper-asl-1.9.13.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/system/lib/janino-2.6.1.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/system/lib/javax.servlet-api-3.1.0.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/system/lib/jcl-over-slf4j-1.7.7.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/system/lib/jersey-core-1.19.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/system/lib/jersey-multipart-1.19.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/system/lib/jersey-server-1.19.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/system/lib/jersey-servlet-1.19.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/system/lib/jetty-http-9.2.4.v20141103.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/system/lib/jetty-io-9.2.4.v20141103.jar:/var/www/neo4j-ent/neo4j-enterprise-2.2.5/syste\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}