$re = '/^([1-9]+|0)(\.[0-9]{1,2})?$/';
$str = '1.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);