using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^. >""])([ ])?([-])?(<\/p>)\n.*?>";
string substitution = @"$1$2";
string input = @"<p class=""calibre1"">pelled itself, riderless, in an endless orbit. </p>
<p class=""calibre1"">The generator complex on the far side of this battlefield was </p>
<p class=""calibre1"">intact, however. Reinforced concrete bunkers bristling with ma-</p>
<p class=""calibre1"">chine guns surrounded a low building. The generators were deep </p>
<p class=""calibre1"">beneath there. So far it looked as if the Covenant had not man-</p>
<p class=""calibre1"">aged to take them, though not for lack of trying. </p>
<p class=""calibre1"">""Contacts ahead,"" Joshua whispered. </p>
<p class=""calibre1"">Four blips appeared on his motion sensor. Friend-or-foe tags </p>
<p class=""calibre1"">identified them as UNSC Marines, Company Charlie. Serial </p>
<p class=""calibre1"">numbers flashed next to the men as his HUD picked them out on a </p>
<p class=""calibre1"">topo map of the area. </p>
<p class=""calibre1"">Joshua handed Fred his sniper rifle, and he sighted the con-</p>
<p class=""calibre1"">tacts through the scope. They were Marines, sure enough. They </p>
<p class=""calibre1"">picked through the bodies that littered the area, looking for sur-</p>
<p class=""calibre1"">vivors and policing weapons and ammo. </p>
<p class=""calibre1"">Fred frowned; something about the way the Marine squad </p>
<p class=""calibre1"">moved didn't feel right. They lacked unit cohesion, with their </p>
<p class=""calibre1"">firstd, <i class=""calibre4"">you may as well drop with good intel. </i> </p>
<p class=""calibre1"">Captain Keyes frowned on the ship's viewscreen, a </p>
<p class=""calibre1"">""Roger that,"" he replied, ""though I think I've had enough surprises for one op."" </p>
<p class=""calibre1"">Kelly chuckled. </p>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}