import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<User>[a-zA-Z1-9\\._]+)@(?P<Domain>[a-zA-Z1-9]+)\\.(?P<D_EXT>[a-zA-Z]+)";
final String string = "my email is andy@delusion.org\n"
+ "my school email is andrew.newton18@mydiscoveryk8.org\n"
+ "daddy's email is mike@delusion.org\n"
+ "Zach H's email is hitchcockzach@gmail.com\n"
+ "Zach R's email is zrambler441@yahoo.com\n"
+ "Ryan's email is ryanmeth@icloud.com\n"
+ "Mateo's email is mateo@relhok.com\n"
+ "Kieran's email is kieran.derrington@gmail.com \n"
+ "Tyler's email is tbone.vaughn@icloud.com\n\n"
+ "DON'T WORK:\n\n"
+ "...@.......\n"
+ "secreretface-2@loans.com\n";
final String subst = "${User} at ${Domain}.${D_EXT}\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}