$re = '/({.*})/U';
$str = 'http://localhost:8080/api/location/remove/{id}/{pemento}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);