$re = '/^[\s\S\r]/';
$str = '
hehehehe
dasdf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);