# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\$([a-z0-9-]+):\s+(.[^;]{3,6}\s*(!default)?);"
test_str = ("\n"
"$color-white: #ffffff !default;\n"
"$color-black: #000000 !default;\n\n"
"$color-gray-lightest: #f5f5f5 !default;\n"
"$color-gray-lighter: #ededed !default;\n"
"$color-gray-light: #e5e3e3 !default;\n"
"$color-gray-mid: #d1d0d0 !default;\n"
"$color-gray-dark: #a3a2a2 !default;\n"
"$color-gray-darker: #636363 !default;\n\n"
"$color-error: #ff0000;\n"
"$color-success: #2cfba5;\n\n"
"$color-brand-group-1-lighter: #f8d9dd !default;\n"
"$color-brand-group-1-light: #de9193 !default;\n"
"$color-brand-group-1: #be2428 !default;\n\n"
"$color-brand-group-2-lightest: #f3f3f3 !default;\n"
"$color-brand-group-2-lighter: #8e97ae !default;\n"
"$color-brand-group-2-light: #77839d !default;\n"
"$color-brand-group-2: #1d305d !default;\n"
"$color-brand-group-2-dark: #0a1c42 !default;\n\n"
"$color-brand-group-3-light: #84d7b6 !default;\n"
"$color-brand-group-3: #0faf6d !default;\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.