const regex = /\$([a-z0-9-]+):\s+(.[^;]{3,6}\s*(!default)?);/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$([a-z0-9-]+):\\s+(.[^;]{3,6}\\s*(!default)?);', 'g')
const str = `
\$color-white: #ffffff !default;
\$color-black: #000000 !default;
\$color-gray-lightest: #f5f5f5 !default;
\$color-gray-lighter: #ededed !default;
\$color-gray-light: #e5e3e3 !default;
\$color-gray-mid: #d1d0d0 !default;
\$color-gray-dark: #a3a2a2 !default;
\$color-gray-darker: #636363 !default;
\$color-error: #ff0000;
\$color-success: #2cfba5;
\$color-brand-group-1-lighter: #f8d9dd !default;
\$color-brand-group-1-light: #de9193 !default;
\$color-brand-group-1: #be2428 !default;
\$color-brand-group-2-lightest: #f3f3f3 !default;
\$color-brand-group-2-lighter: #8e97ae !default;
\$color-brand-group-2-light: #77839d !default;
\$color-brand-group-2: #1d305d !default;
\$color-brand-group-2-dark: #0a1c42 !default;
\$color-brand-group-3-light: #84d7b6 !default;
\$color-brand-group-3: #0faf6d !default;
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}