import Foundation
let pattern = #"^[1-9]\d{2}(0[1-9]|1[0-2])(0[1-9]|[12]\d|3[01])(0[1-9]|[1-4]\d|5[0-2]|99)(00[1-9]|0[1-9]\d|[1-9]\d\d)\d$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1870818340915"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"CNPJ"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)