package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[1-9]\d{2}(0[1-9]|1[0-2])(0[1-9]|[12]\d|3[01])(0[1-9]|[1-4]\d|5[0-2]|99)(00[1-9]|0[1-9]\d|[1-9]\d\d)\d$`)
var str = `1870818340915`
var substitution = "CNPJ"
fmt.Println(re.ReplaceAllString(str, substitution))
}