using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[1-9]\d{2}(0[1-9]|1[0-2])(0[1-9]|[12]\d|3[01])(0[1-9]|[1-4]\d|5[0-2]|99)(00[1-9]|0[1-9]\d|[1-9]\d\d)\d$";
string substitution = @"CNPJ";
string input = @"1870818340915";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}