# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*?)(?<abc>[a-zA-Z]{4})(.*)/${abc}/gm;t' <<< "OTIN2ZkZmYtMjc4MS00MGRiLTkyMjctODdhNzBkZWI5ZmIx"