// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[0-9A-Za-z.@]+:[0-z]+").unwrap();
let string = "len.simms@talktalk.net:sophie1
Status: Premium
Storage available: 6 TB of 6 TB
Payout sum: $0.00
Bandwith available: 495.88 GB of 3 TB
E-mail: len.simms@talktalk.net
------------
tabbott85@hotmail.co.uk:jeneva
Status: Premium
Storage available: unlimited
Payout sum: $0.00
Bandwith available: 465.4 GB of 1 TB
E-mail: tabbott85@hotmail.co.uk";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}