use strict;
my $str = 'len.simms@talktalk.net:sophie1
Status: Premium
Storage available: 6 TB of 6 TB
Payout sum: $0.00
Bandwith available: 495.88 GB of 3 TB
E-mail: len.simms@talktalk.net
------------
tabbott85@hotmail.co.uk:jeneva
Status: Premium
Storage available: unlimited
Payout sum: $0.00
Bandwith available: 465.4 GB of 1 TB
E-mail: tabbott85@hotmail.co.uk';
my $regex = qr/[0-9A-Za-z.@]+:[0-z]+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}