using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9A-Za-z.@]+:[0-z]+";
string input = @"len.simms@talktalk.net:sophie1
Status: Premium
Storage available: 6 TB of 6 TB
Payout sum: $0.00
Bandwith available: 495.88 GB of 3 TB
E-mail: len.simms@talktalk.net
------------
tabbott85@hotmail.co.uk:jeneva
Status: Premium
Storage available: unlimited
Payout sum: $0.00
Bandwith available: 465.4 GB of 1 TB
E-mail: tabbott85@hotmail.co.uk";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}