$re = '/(Attached file: )(.....)\....$/';
$str = 'Attached file: 79349.doc';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);