use strict;
my $str = 'www.twanda.ch/store/apps/details?id=com.skgames.trafficracer%22
www.twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22
twanda.ch/store/apps/details?id=com.skgames.trafficracer%22
twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22
http://twanda.ch/store/apps/details?id=com.skgames.trafficracer%22
https://twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22
http://www.twanda.ch/store/apps/details?id=com.skgames.trafficracer%22
http://www.twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22
https://www.twanda.ch/store/apps/details?id=com.skgames.trafficracer%22
https://www.twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22
flohmarkt-zug.twanda.ch/store/apps/details?id=com.skgames.trafficracer%22
flohmarkt-zug.twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22
http://flohmarkt-zug.twanda.ch/store/apps/details?id=com.skgames.trafficracer%22
http://flohmarkt-zug.twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22
https://flohmarkt-zug.twanda.ch/store/apps/details?id=com.skgames.trafficracer%22
https://flohmarkt-zug.twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22
www.flohmarkt-zug.ch/store/apps/details?id=com.skgames.trafficracer%22
www.flohmarkt-zug.ch:8069/store/apps/details?id=com.skgames.trafficracer%22
flohmarkt-zug.ch/store/apps/details?id=com.skgames.trafficracer%22
flohmarkt-zug.ch:8069/store/apps/details?id=com.skgames.trafficracer%22
http://www.flohmarkt-zug.ch/store/apps/details?id=com.skgames.trafficracer%22
http://www.flohmarkt-zug.ch:8069/store/apps/details?id=com.skgames.trafficracer%22
https://www.flohmarkt-zug.ch/store/apps/details?id=com.skgames.trafficracer%22
https://www.flohmarkt-zug.ch:8069/store/apps/details?id=com.skgames.trafficracer%22
www.twanda.com/store/apps/details?id=com.skgames.trafficracer%22
www.twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22
twanda.com/store/apps/details?id=com.skgames.trafficracer%22
twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22
http://www.twanda.com/store/apps/details?id=com.skgames.trafficracer%22
http://www.twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22
https://www.twanda.com/store/apps/details?id=com.skgames.trafficracer%22
https://www.twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22
flohmarkt-zug.twanda.com/store/apps/details?id=com.skgames.trafficracer%22
flohmarkt-zug.twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22
http://flohmarkt-zug.twanda.com/store/apps/details?id=com.skgames.trafficracer%22
http://flohmarkt-zug.twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22
https://flohmarkt-zug.twanda.com/store/apps/details?id=com.skgames.trafficracer%22
https://flohmarkt-zug.twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22
www.flohmarkt-zug.com/store/apps/details?id=com.skgames.trafficracer%22
www.flohmarkt-zug.com:8069/store/apps/details?id=com.skgames.trafficracer%22
flohmarkt-zug.com/store/apps/details?id=com.skgames.trafficracer%22
flohmarkt-zug.com:8069/store/apps/details?id=com.skgames.trafficracer%22
http://www.flohmarkt-zug.com/store/apps/details?id=com.skgames.trafficracer%22
http://www.flohmarkt-zug.com:8069/store/apps/details?id=com.skgames.trafficracer%22
https://www.flohmarkt-zug.com/store/apps/details?id=com.skgames.trafficracer%22
https://www.flohmarkt-zug.com:8069/store/apps/details?id=com.skgames.trafficracer%22
';
my $regex = qr/^(http://|https://|http://www\.|https://www\.|www\.)?(www\.(twanda))?(([\w\-]+)?\.?(twanda|))(\.ch|\.com)(:\d+)?/.+$/imp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";