import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(http://|https://|http://www\\.|https://www\\.|www\\.)?(www\\.(twanda))?(([\\w\\-]+)?\\.?(twanda|))(\\.ch|\\.com)(:\\d+)?/.+$";
final String string = "www.twanda.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "www.twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "twanda.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "http://twanda.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "https://twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "http://www.twanda.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "http://www.twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "https://www.twanda.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "https://www.twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "flohmarkt-zug.twanda.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "flohmarkt-zug.twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "http://flohmarkt-zug.twanda.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "http://flohmarkt-zug.twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "https://flohmarkt-zug.twanda.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "https://flohmarkt-zug.twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "www.flohmarkt-zug.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "www.flohmarkt-zug.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "flohmarkt-zug.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "flohmarkt-zug.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "http://www.flohmarkt-zug.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "http://www.flohmarkt-zug.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "https://www.flohmarkt-zug.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "https://www.flohmarkt-zug.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "www.twanda.com/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "www.twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "twanda.com/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "http://www.twanda.com/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "http://www.twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "https://www.twanda.com/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "https://www.twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "flohmarkt-zug.twanda.com/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "flohmarkt-zug.twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "http://flohmarkt-zug.twanda.com/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "http://flohmarkt-zug.twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "https://flohmarkt-zug.twanda.com/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "https://flohmarkt-zug.twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "www.flohmarkt-zug.com/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "www.flohmarkt-zug.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "flohmarkt-zug.com/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "flohmarkt-zug.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "http://www.flohmarkt-zug.com/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "http://www.flohmarkt-zug.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "https://www.flohmarkt-zug.com/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "https://www.flohmarkt-zug.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}