using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z]{4})\s*([0-9]{6})[\s-\/]?([0-9])";
string input = @"ABCD 4568521";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}