$re = '/Country:[\s]+(\S{2})/i';
$str = 'City: Redmond
StateProv: WA
PostalCode: 98052
Country: US';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);