$re = '/^[_A-Z]+$/m';
$str = 'FOOBAR
FOO BAR
VELO
TÖFF
MOTORAD_FAHREN
FOO__BAR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);