using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[_A-Z]+$";
string input = @"FOOBAR
FOO BAR
VELO
TÖFF
MOTORAD_FAHREN
FOO__BAR";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}