$re = '/^(([0-1][0-9]|2[0-3]):[0-5][0-9])$/m';
$str = '17:30
24:00
19:11:07
00:00
23:59
5:50';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);