package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([0-1][0-9]|2[0-3]):[0-5][0-9])$`)
var str = `17:30
24:00
19:11:07
00:00
23:59
5:50`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}