// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)((([\w\s]+|\\,|\\'|\\;)+)(?:,?\s*))").unwrap();
let string = "'Dimensi on\\, Na me1, Dimen\\; si\\'onName2, DimensionName3,DimensionName4, DimensionName5, DimensionName6";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}