$re = '/((([\w\s]+|\\\\,|\\\\\'|\\\\;)+)(?:,?\s*))/i';
$str = '\'Dimensi on\\, Na me1, Dimen\\; si\\\'onName2, DimensionName3,DimensionName4, DimensionName5, DimensionName6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);