import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((([\\w\\s]+|\\\\,|\\\\'|\\\\;)+)(?:,?\\s*))";
final String string = "'Dimensi on\\, Na me1, Dimen\\; si\\'onName2, DimensionName3,DimensionName4, DimensionName5, DimensionName6";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}