package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)((([\w\s]+|\\,|\\'|\\;)+)(?:,?\s*))`)
var str = `'Dimensi on\, Na me1, Dimen\; si\'onName2, DimensionName3,DimensionName4, DimensionName5, DimensionName6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}