use strict;
my $str = '$schedules[\'fiveminute\'] = array(
\'interval\' => 300,
\'display\' => __(\'Every 5 minutes\')
);
return $schedules;
return array(
\'success\' => true,
\'msg\' => __(\'Your password have updated successfull. You can login with your new password now.\', ET_DOMAIN)
);';
my $regex = qr/__\([\s]?'([^']*?)'[\s]?\)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}