using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"__\([\s]?'([^']*?)'[\s]?\)";
string input = @"$schedules['fiveminute'] = array(
'interval' => 300,
'display' => __('Every 5 minutes')
);
return $schedules;
return array(
'success' => true,
'msg' => __('Your password have updated successfull. You can login with your new password now.', ET_DOMAIN)
);";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}