#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "__\([\s]?'([^']*?)'[\s]?\)"
Local $sString = "$schedules['fiveminute'] = array(" & @CRLF & _
" 'interval' => 300," & @CRLF & _
" 'display' => __('Every 5 minutes')" & @CRLF & _
");" & @CRLF & _
"return $schedules;" & @CRLF & _
"" & @CRLF & _
"return array(" & @CRLF & _
" 'success' => true," & @CRLF & _
" 'msg' => __('Your password have updated successfull. You can login with your new password now.', ET_DOMAIN)" & @CRLF & _
");"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")