$re = '/^((|[0-1])[1-9]:[0-5][0-9](| )(am|pm))$/';
$str = '11:38 am';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);