using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(zip|postal code|code postal):?";
string input = @"zip bro";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}