import Foundation
let pattern = #"((?:[A-Z]\w+).+?(?i)(?:agreement|amendment|addendum|contract|license|rights(?: and obligations)?|laws?|terms)(?!\.).+?(?:governe?d?|controll?e?d?|interprete?d?|construed?|appl(?:ied|y)|determined?).+?(?:laws?|provisions?|matters).*?\.)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"The terms of the Governing Law and Dispute Resolution provisions of the Distribution Agreement will apply to this Addendum."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)