$re = '/((?:[A-Z]\w+).+?(?i)(?:agreement|amendment|addendum|contract|license|rights(?: and obligations)?|laws?|terms)(?!\.).+?(?:governe?d?|controll?e?d?|interprete?d?|construed?|appl(?:ied|y)|determined?).+?(?:laws?|provisions?|matters).*?\.)/m';
$str = 'The terms of the Governing Law and Dispute Resolution provisions of the Distribution Agreement will apply to this Addendum.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);