const regex = /((?:[A-Z]\w+).+?(?i)(?:agreement|amendment|addendum|contract|license|rights(?: and obligations)?|laws?|terms)(?!\.).+?(?:governe?d?|controll?e?d?|interprete?d?|construed?|appl(?:ied|y)|determined?).+?(?:laws?|provisions?|matters).*?\.)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:[A-Z]\\w+).+?(?i)(?:agreement|amendment|addendum|contract|license|rights(?: and obligations)?|laws?|terms)(?!\\.).+?(?:governe?d?|controll?e?d?|interprete?d?|construed?|appl(?:ied|y)|determined?).+?(?:laws?|provisions?|matters).*?\\.)', 'gm')
const str = `The terms of the Governing Law and Dispute Resolution provisions of the Distribution Agreement will apply to this Addendum.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}