import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:[A-Z]\\w+).+?(?i)(?:agreement|amendment|addendum|contract|license|rights(?: and obligations)?|laws?|terms)(?!\\.).+?(?:governe?d?|controll?e?d?|interprete?d?|construed?|appl(?:ied|y)|determined?).+?(?:laws?|provisions?|matters).*?\\.)";
final String string = "The terms of the Governing Law and Dispute Resolution provisions of the Distribution Agreement will apply to this Addendum.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}