$re = '/[a-zA-Z-0-9]+/i';
$str = 'acessorios-e-equipamentos-para-pintura_1_6_658_1_0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);