package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:.*?)\{(.*?)\}(?:[\[((.*?))\]]*|[\{(.*?)\}]*)`)
var str = `\DeclarePairedDelimiterX{\Set}[2]\{\}{\,#1\;\delimsize\colon\; #2 \,}
\DeclarePairedDelimiter{\card}{\vert}{\vert}
\DeclarePairedDelimiter{\abs}{\vert}{\vert}
\DeclarePairedDelimiter{\norm}{\vert}{\vert}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}